top of page

Grupo Colmi

Público·4 miembros

Download Drop 124014 (1)


firstly you need to import the Select class and then you need to create the instance of Select class.After creating the instance of Select class, you can perform select methods on that instance to select the options from dropdown list.Here is the code




Download drop 124014 (1)



To select an element from a html-select menu you have to use the Select Class. Moreover, as you have to interact with the drop-down-menu you have to induce WebDriverWait for the element_to_be_clickable().


I tried a lot many things, but my drop down was inside a table and I was not able to perform a simple select operation. Only the below solution worked. Here I am highlighting drop down elem and pressing down arrow until getting the desired value -


After going through a lot of posts like this one, I managed to figure out a solution that allowed me to select an item in a dropdown. I tried .send_keys, click(), and Select in various ways with no success. Ended up sending the click() command to the dropdown 3 times before clicking on the item in the dropdown.


I figured this was a layer 2 or 3 problem but I cannot seem to find an issue anywhere. The Master controller and the primary RADIUS server are on the same local subnet. They're even on the same switch. I do not see any errors on my switch. I don't see any timeout errors on my NPS RADIUS logs. I ran a continual ping from the RADIUS server to the local controller and didn't drop a single packet while things were working correctly AND while they weren't. The NPS server was brought up specifically for this wireless deployment and it is not doing anything else at the moment. Looking through the NPS logs it's serving/denying clients maybe every couple seconds so it can't be overloaded.


Approximately 41 minutes later the Master controller decided the Primary RADIUS server was back up and started sending traffic to it. This entire time the RADIUS server was continually pinging the Master controller without dropping a packet. As I mentioned above, the NPS logs don't show anything unusual right up to and during this event.


The ping I've been running from this 'unresponsive' RADIUS server to the Aruba controller still hasn't dropped a single packet - up to 170,000 consecutative responses now. Obviously this doesn't rule out the RADIUS processes on the server being "too busy" but it does make me think there is not a problem at layer 2/3.


I wish I could be of more help. I'm writing this hoping that it might get someone on the right track. If you're reading this and think you might have the same issue, drop down to a single RADIUS server and see if the experience on the CLIENT end gets better (the controller will still complain about the server going 'down' as long as you have iDevices).


To be completely honest I did the bulk of my troubleshooting a year ago and decided to drop down to the single RADIUS server. After working up the chain at Aruba support and not getting a resolution, I kind of crossed it off my list and haven't thought about it since.


Sorry to bump this up, but I have been looking at a similar, ney, identical problem. I have a TAC case (#1440376) and am still waiting for a period when I see consecutive drops and can capture it with Wireshark. I also have security debugging enabled. My issue is that it is only affecting two radius servers for one auth group when other servers have been up as long as the controller was last rebooted.


I too can find no network issues and the server team report nothing amiss with the radius server (Tokyo to Hong Kong), the MPLS network is fine, it never drops a single packet and sits at 50ms response time....always.


The issue was due to the first radius frame being sent from the controller with the df bit set, so the frame was dropped and the controller would still wait for a reply. None was received, so it would then mark the server as down for 10 mins, which I think is the default dead timer. The workaround was to set the auth dead time to 0 - Case # 1440376. 041b061a72


Acerca de

¡Te damos la bienvenida al grupo! Puedes conectarte con otro...
bottom of page